very hot water, lukewarm rads


Postby davy » Wed Jan 07, 2009 2:04 pm

my problem is as follows: the boiler switches on and off quite rapidly and whilst the rads do warm up but not hot, the water gets mega hot.
Finally the boiler shuts down and i lose all heat.
I then run off the very hot water into the bath and an airlock seems to happen as the water splutters out ( discoloured ) and then the boiler will restart. I have had a new pump installed by a plumber who now thinks the 3 port valve may need renewing, any ideas? davy
davy
Rank: Labourer
Progress to next rank:
25%
Posts: 2
Joined: Wed Jan 07, 2009 1:38 pm

Sponsor

Simply Build It

Postby Steve the gas » Thu Jan 08, 2009 5:57 am

Hi Davy,

Need more info on system as much info as you can give.
Steve the gas
Rank: Site Agent
Progress to next rank:
56%
Posts: 780
Joined: Sun May 04, 2008 7:07 am

Postby davy » Fri Jan 09, 2009 4:04 pm

hi steve, the boiler is a Myson Economist WF30/40 BF, about 20 years old. There are 5 rads plus a towel rad in bathroom.
Water tank and new Grunfoss pump, Honeywell 3 port valve are in loft. thats about it.
By the way I have water switched OFF on the Centaur Plus C27 controller, but still get mega hot water. Davy
davy
Rank: Labourer
Progress to next rank:
25%
Posts: 2
Joined: Wed Jan 07, 2009 1:38 pm

Postby Steve the gas » Sat Jan 10, 2009 8:13 am

Hi,

Could you lock the slider on 3 port valve to the manual position and post back?
Steve the gas
Rank: Site Agent
Progress to next rank:
56%
Posts: 780
Joined: Sun May 04, 2008 7:07 am

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics