Weak centre flame on Cannon Misermatic Deluxe

Postby aidb » Sun Oct 05, 2008 7:54 am

Hi everyone, :)

When I ignite my gas fire it lights the centre part. (Position 1 on dial) fine, but compared to the other four settings, it's a very weak flame. The fire's pretty old, but still a good 'un. Any help would be greatly appreciated.

Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sun Oct 05, 2008 7:44 am


Simply Build It

Postby htg engineer » Tue Oct 21, 2008 6:53 pm

Could be a number of things, dirty burner, blocked injector etc etc.

Would be best to get a RGI out to service the fire and see if they can rectify the problem. Annual gas services are often overlooked with private properties. This is the main reason appliance breakdown and become dangerous. Having the fire serviced regularly will ensure the safety of the installation and any wear and tear can be rectified at an early stage before the parts become too worn, if it's an old fire the parts may now be obsolete.

htg engineer
Rank: Project Manager
Posts: 3224
Joined: Tue May 22, 2007 5:22 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics