Worcester 240 Combi OF! Help

Postby highlander1403 » Sun May 25, 2008 11:39 pm

Hi Ya
Having problems with the above combi, basically it doesn’t work at the mo! Can light the pilot light and as soon as the switch is activated to go in to heating mode it lights the main burner in the combustion area for approximately 10 to 15 secs the goes out.
The flame in the combustion area seems to have excessive flames (set on min & max) and within this short period the pilot light flicker continuously then the system goes out.
Obviously any guidance/help would be much appreciated and yes I did have it serviced about three months ago
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sun May 25, 2008 9:02 pm


Simply Build It

Postby lisdar » Mon May 26, 2008 12:05 pm

Sounds like the fan is not running or combustion chamber or flue blocked
and blowing back is the flame you can see
Rank: Apprentice
Progress to next rank:
Posts: 5
Joined: Fri May 16, 2008 1:17 pm

Postby htg engineer » Mon May 26, 2008 8:43 pm

Worcester 240 OF - open flue ?
Fan ????? there wont be one.

Check pump, if heat isn't getting away from boiler it'll cut out, excessive flames ? check diverter may be stuck in hot water mode - will be higher gas rate also heat cannot escape without tap being opened - so diverter may be the problem.

htg engineer
Rank: Project Manager
Posts: 3224
Joined: Tue May 22, 2007 5:22 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics