worcester greenstar 30CDi System boiler

Postby fsd123 » Fri Aug 24, 2012 9:26 pm

Hi all
we have the above boiler which is producing hot water fine but suddenly no heating. So I noticed the pressure had dropped to almost 0 so repressurised to 1 but that did not help. I checked all the radiators did not need bleeding then tried the RESET button. Then I tried turning off and on. There are no error codes or warning lights or funny noises. The blue mains light stays on (i.e. no flashing) and the digital display hovers around 70. I turned the Honeywell wireless HCW80 thermostat up(I even changed the batteries just in case). I think the green burner light is supposed to come on when heating maybe but it does not.
There is a central heating temperature dial on the control panel and turning that up did not help.
Any comments would be very gratefully received.
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Fri Aug 24, 2012 8:39 pm


Simply Build It

Postby plumbbob » Sat Aug 25, 2012 6:40 pm

If the boiler is producing hot water ok then the problem does not lie there.

Check the room thermostat receiver is functioning correctly. It is the most likely cause of the problem.

Any more info about the system would be useful in helping a diagnosis.
Rank: Project Manager
Posts: 1870
Joined: Wed May 07, 2008 9:59 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics