DIY Doctor

Different Pressures With Glowworm Flexicom 30sx

Postby Stevolution2020 » Wed Apr 29, 2020 1:53 pm

Hello all.
We have a Glowworm Flexicom 30sx.
Once a year/18 months, it bails out on an F9 error (it is serviced).

We traced this to be the CH pressure sensor.

18 months on.... it went again. We have appalling water here, and our softener hasn't helped (maybe made it worse?).

Anyway, I had bought a spare, so I isolated the boiler and swapped it out.
Bled all the rads and it fired up fine. But...

The airing cupboard gauge shows 1.5 bar, and the boiler shows 2.1.
Wrong sensor? Just checked DHWspares online where is came from and it seems correct.
But, it was all working. However... just glanced at the boiler and it said 0.3bar.
Switched it off and on again and 2.1 bar came back. Fires up fine.

Any ideas?
Stevolution2020
Rank: Labourer
Progress to next rank:
25%
Posts: 2
Joined: Wed Apr 29, 2020 1:47 pm


Sponsor

Simply Build It

Postby Stevolution2020 » Wed Apr 29, 2020 8:40 pm

Just as an update.... seems to be fine (at the moment).
Boiler shows 2 bar, airing cupboard gauge shows 1.6 bar.
Maybe they never matched?
Stevolution2020
Rank: Labourer
Progress to next rank:
25%
Posts: 2
Joined: Wed Apr 29, 2020 1:47 pm



Display posts from previous
Sort by
Order by



  • DIY How to Project Guides
  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


 
  • Related Topics