Older EuroCombi SX20 Help Required With Temp Setting Problem


Postby PaulF » Sat Feb 10, 2018 4:30 pm

Hi all. We have an older EuroCombi SX20 - not very complicated boiler but....over the past 2 yeers every single compenent except expansion chamber has been replaced. So what the problem - well it's a 90 degree rated boiler which it does on a rare ocassion reach - most of the time it's 78-80 - which having had it for 20 years is not enough to "throw" heat into the house, meaning it's normally bloody coldish.
At 82 deg the rads are running at 64-73 degrees.
OK you say again - so whats the problem....
On the control panel we have 1 control for the CH temp - whether this is at lowest setting on left or highest on right it makes absoltly NO difference to the temp - it still runs and reached the same regardless of the position or the time it takes to get there. So in effect we have a 1 temp boiler...relying on TRV's to adjust rooms - though hardly necessary - We have just replaced that same controller twice in last week with new units and rebalanced all the rads - and the results are still the same...
Thats the 1st issue the 2nd one is the time it takes to get to temp - around 2/3 hours!!!! Even the guys from Scottish Gas say thats strange in the extreme.
So - whos up for a good solution then???
PaulF
Rank: Labourer
Progress to next rank:
50%
Posts: 3
Joined: Tue Jan 02, 2018 1:09 pm

Sponsor

Simply Build It


  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics