DIY Doctor

Zanussi ZDF26011WA Dishwasher only heating slightly

Postby kcr123 » Tue Apr 13, 2021 12:28 am

My five year old Zanussi ZDF26011WA dishwasher is not heating correctly. On the Auto cycle, the water heats to around 38 degrees near the start of the cycle, but never reaches full temperature, and finishes cold (normally finishes hot and steaming when opened).
I have checked the following:
- Temp sensor appeared to return the correct resistance readings. I tried replacing it anyway, which made no difference
- Heater measures 24 ohms, which seems to be about right for the 2kW rating
- I can measure 12 V on the control board heater relay in the early part of the cycle, and 240V going to the heater, so the heating circuit appears to be OK, but it only seems to heat for a short period at the start of the cycle
- Pump appears to be working fine and water is spraying
- I have cleaned everything out and checked the channel to the pressure switch is clear
So the components (as far as I can check) seem to be OK, it just isn't heating for very long. Can anyone suggest what might be wrong, or anything else I can investigate?
Thanks
kcr123
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Tue Apr 13, 2021 12:27 am


Sponsor

Simply Build It



  • DIY How to Project Guides
  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


 
  • Related Topics