Central Heating losing pressure

Postby garyn31 » Wed Dec 22, 2010 2:15 pm

My central heating system has been losing pressure for approx 1 year (An old Vaillant 24Kw combi boiler).
I have been topping up periodically.
I have recently had a Vaillant Eco Plus 837 fitted and still losing pressure (Approx 1 bar in 3 days).
Only 1 radiator is losing heat (bathroom, no thermostat), i have bled this twice in 3 days then the system loses pressure. I have topped it up to 1.4 bar. There are no signs of water damage to any of the ceilings. :(
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Wed Dec 22, 2010 2:06 pm


Simply Build It

Postby stoneyboy » Thu Dec 23, 2010 12:26 pm

My top 3 suggestions are:
1. You have a leak somewhere in the system - add a leak sealer
2. The pressure vessel is faulty - replace the pressure vessel
3. System preserver has not been added and corrosion gases are being produced - add preserver to the system
I'm sure other forum members will have other suggestions.
Rank: Project Manager
Posts: 2715
Joined: Wed Dec 10, 2008 6:44 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics