Cold radiators

Postby allenja » Tue May 15, 2007 12:58 pm

I have a baxi back boiler with 6 radiators.

We removed one radiator the other day to alter the pipe work as it had been fitted so badly, whilst we were fitting it we also drained the header tank in the loft and tied up the ball valve.

Once the new rad was fitted we filled up the header tank and opened the rad valves.

Ever since only 3 of the radiators are working, the one that was removed is working fine. I have tried bleeding the rads with the heating off but there is no air coming from them just water. I have also bled the air valve up in the loft.

When the heating is on the feed pipes to the cold radiators are not even getting hot. I would guess there is an air lock somewhere in the system but have no idead of how to free it. Can someone please help??? Up until the rad was removed all was fine!
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Tue May 15, 2007 12:51 pm


Simply Build It

Postby Paul Pepper » Tue May 15, 2007 6:13 pm

Try switching off all rads (and hot water) bar one that is not working, and turning the pump and boiler stat up to max. Should clear most airlocks, depending on how stubborn it is!

Paul Pepper
Rank: Tradesman
Progress to next rank:
Posts: 38
Joined: Fri May 11, 2007 6:02 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics