Hot down, cold up!


Postby Nhallg » Mon Nov 26, 2007 5:41 pm

Hello,
Winter approaches and I need to sort out this long-standing problem...downstairs rads are piping hot, upstairs cold. Baxi back boiler works fine, pump is good. Ive tried turning off the rads upstairs and on again one at a time. Ive tried bleeding them all, and get cold water which appears to be under some pressure; it spurts rather than dribbles if I completely remove the valve. I've checked the tank in the loft too. The system is about 30 years old, but some new rads were added before I bought the house. It all worked ok for a couple of years.
Any advice would be greatly appreciated.
Thank you very much

Norman
Nhallg
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Mon Nov 26, 2007 5:33 pm

Sponsor

Simply Build It

Postby htg engineer » Wed Nov 28, 2007 9:15 pm

turn off or turn down all downstairs radiators, and check pump is on III setting. Could be blockage in manifolds - is there water flowing and flow and return of radiators ?
htg engineer
Rank: Project Manager
Posts: 3224
Joined: Tue May 22, 2007 5:22 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics