Immersion heater problems

Postby merlin101 » Sun Jul 15, 2007 3:36 pm

I've recently had my immersion heater changed and it worked fine for a couple of months but now it isn't heating the water properly. When it is switched on it appears to be heating up fine but when I switch the hot tap on it runs hot for a minute or two then turns freezing cold. It does this even if it has been on for several hours. I have tried changing the timer and the thermostat but don't understand what can be causing this problem. please can you help.
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sun Jul 15, 2007 3:32 pm


Simply Build It

Postby johnb » Tue Jul 17, 2007 4:26 pm

hi merlin if your thermostat is the new version it will have a reset button on top try reseting, if it doesnt then you have the old illegal version which should not have been sold to you .you can test the thermostat live with a mains tester if you are confident as to what you are doing it should read live both sides all the best john
Rank: Ganger
Progress to next rank:
Posts: 83
Joined: Fri Jul 13, 2007 9:09 am

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics