keston celsius 25 problem firing

Postby baldilocks » Tue Nov 25, 2008 10:00 pm

hi i have the unfortunate luck to own a house with the celsius 25 and have had experience with others on our estate.

the issue at the moment seems to be that it will not fire, it goes through the start up sequence but after the 4th attempt locks out, i thought aha thermo couple but it's electronic ignition, so phoned Keston direct and they said spark electrode, so after an almighty muck up on the behalf of HRP, i finally have one today a week later i've just fitted it and hey presto still doesn't fire, my meager conclusion draws me to gas valve as there is gas before the solenoid but nothing after or the pcb board as i haven't heard the thing spark (even tried it like you do with a car external with an earth point secured to it) help cause it's cold
Rank: Labourer
Progress to next rank:
Posts: 4
Joined: Tue Nov 25, 2008 9:45 pm


Simply Build It

Postby TheDoctor5 » Fri Jan 30, 2009 11:01 am

If you type the key words of your question into our search box to the left of the site you may find the answer is already posted or is in the DIY projects section of the website. Every post goes through a monitoring process and using the search box may speed up your answer.
Posts: 1382
Joined: Tue Jan 20, 2009 9:17 am

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics