No heat to first floor rads

Postby golfing1972 » Tue Nov 25, 2008 4:37 pm


Weekend project of changing old bathroom rad for new swish chrome towel rad, tied ball valve, drained system, disconnected rad, altered pipework to fit new, re-connected ball valve, filled up system, slapped myself on back for job well done!

Switched heating on to check - no heat to first floor, ground floor roasting, missus not happy.

bled everywhere till water came out, tried switching ground floor rads off which got the new towel rad slightly warm (think its the first on system to first floor) missus moaned as lounge freezing so had to switch back on.

Right its a fairly old (on ground floor) boiler and tank, no rad TRVs just old on/off valves. System regularly serviced and all working a treat up till new rad installation. Thinking possibly air lock stuck between floors??? faulty valves with new rad??? (but rad full of water) gonna try draining system at bleed valves to see if that helps shifting anything?

Anyone gotta any ideas?

Thanks in anticipation..... :(
Rank: Labourer
Progress to next rank:
Posts: 3
Joined: Tue Nov 25, 2008 4:13 pm


Simply Build It

Postby Steve the gas » Wed Nov 26, 2008 5:32 am


Check and bleed the pump--- big screw in middle-- take it out to see if turning?
Steve the gas
Rank: Site Agent
Progress to next rank:
Posts: 780
Joined: Sun May 04, 2008 7:07 am

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics