No hot water from shower

Postby nik28 » Sun May 06, 2007 11:02 pm

My husband has recently installed a new 8.5 kw electric shower (shower force). we previously had a 8.5 kw shower - gainsborough, i think.
we have a worcester combi boiler.

the shower is plumbed in correctly as there is water running from it, the standby light comes on so there is electicity going to it, however when on the water remains cold. no hot water at all.

Any ideas what the problem might be. Any advice would be really appreciated.[/b]
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sun May 06, 2007 10:51 pm


Simply Build It

Postby sparx » Mon May 07, 2007 9:26 am

If this has been a problem from begining check there isn't a small ribbon cable from main shower to front panel not connected, also if air got in pipe shower may have tripped on overheat 'stat in side which sometimes can be reset, it sits on top/near top of copper 'pot'. regards SPARX
(note type of boiler not relevent as shower only has mains cold water supply)
Rank: Project Manager
Posts: 2166
Joined: Wed Mar 21, 2007 8:33 pm
Location: The fifth continent.

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics