No hot water or central heating


Postby rigour » Wed Oct 29, 2008 12:03 pm

Hi,

I have a Baxi Bermuda 675 back boiler and the problem is that I do not have any hot water or central heating. The pilot light is lit and the controller is on and the room thermostat is all on maximum. The boiler thermostat is also on maximum. When the controller on button is pressed and held in you can here a sparking/electricity sound coming from the boiler area. When if it does manage to fully lit up you hear that same sound but but then the gas flames quickly go out and the noise stops. Any thoughts of which component(s) to look at or any further diagnostics?
Thanks in advance

Rigour
rigour
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Wed Oct 29, 2008 11:51 am

Sponsor

Simply Build It

Postby htg engineer » Thu Oct 30, 2008 3:41 pm

There should be no sparking sound as this is a permanent pilot - not electronic ignition. So there's an electrical fault, maybe a loose connection on the thermostat or gas valve - either way not a DIY job you need a RGI to repair.


htg
htg engineer
Rank: Project Manager
Posts: 3224
Joined: Tue May 22, 2007 5:22 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics