Protherm 80E Problem

Postby wasp » Sun Jan 08, 2012 9:14 pm

Hi there,
I have a protherm 80E combi boiler that is used for 5 rads, a shower and 2 sinks. It often displays the F1 fault and I am aware that this is a common fault with this boiler. I have had several engineers come out and look at it, but none have been able to fix the problem, even after several new parts.

To overcome this, my partner and I just rotate on 'boiler watch' at shower times and just reset it if the heating goes off. However, this has been happening more and more often and a new fault has begun too. Now the boiler will just lose it's flame, but not display any fault. Sometimes it will reset itself if you turn the boiler off at the wall for a few seconds, but now this is not even working.

What could be the problem and how do we fix this. There is no way we can afford a new boiler, but we are fed up of freezing to death and having cold showers :-( Please help...
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sun Jan 08, 2012 9:05 pm


Simply Build It

Postby plastic_man77 » Tue Jan 10, 2012 4:47 pm

@ wasp

There are two primary reasons for the F1 fault code to be displayed, flame sensing and overheating, but there are several causes for each.

What parts have been changed so far?
Rank: Ganger
Progress to next rank:
Posts: 71
Joined: Thu Dec 30, 2010 9:04 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics