Radiators are still hot (not all) even though thermostat off


Postby pixie1 » Tue Feb 17, 2009 7:19 pm

We have been having problems with our central heating for a few weeks...
We have a combi boiler which is always on, which heats hot water/radiators separately.
We also have a thermostat which has 3 settings - off, manual (turns heating straight on and overrides auto) and auto (cuts off at a certain temp/time). We normally have it on auto when we are in and then turn it off at other times.

Recently we have been turning it off, and finding that some of the radiators are still partially hot (this has never happened before). They do not go cold either- they are constantly on.

Is something broken?
The thermostat is digital.
Thanks
pixie1
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Tue Feb 17, 2009 7:12 pm

Sponsor

Simply Build It

Postby rosebery » Tue Feb 17, 2009 9:55 pm

Sounds like diverter gone on the blink.

Boiler details etc for the boiler guys will get you a better answer.

Cheers
rosebery
Rank: Project Manager
Posts: 2022
Joined: Wed Sep 26, 2007 8:55 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics