Valliant Turbo Max Central Heating Boiler


Postby agdene » Thu Dec 10, 2009 8:03 am

Help Damsel in distress.

I have a Valliant Turbo Max 7 yrs old and for the past 3 days I have when running hot water noticed that the radiators are warm in all rooms. I removed all the timer settings to off and it continued.

I phoned my engineer who services it and was told to switch the water dial to quarter past then off then back to 12. I repeated this for the radiator dial but this morning the water is luke warm and the radiators are on also.

I then switched the radiator controls to off and tried again still luke warm water and rads on. Anyone an idea of why I am getting heating on when all switches are off. My work colleague suggested a diverter valve not working correctly. Please help I am at my wits end with this.

Thanks
agdene
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Thu Dec 10, 2009 7:51 am

Sponsor

Simply Build It

Postby htg engineer » Thu Dec 10, 2009 8:02 pm

Yep it's the diverter - the valve is not closing fully when the hot water is being used, the heat that should heat the water is being lost to the heating/radiators.


htg
htg engineer
Rank: Project Manager
Posts: 3224
Joined: Tue May 22, 2007 5:22 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics