water pressure problem with shower


Postby refurbish18 » Fri Mar 11, 2011 2:49 pm

Hi

We have a New Team electric shower that has been running for some time without any problems. Recently the Low Pressure indicator light has started to come on halfway through a shower, the water obviously turns off but then the light goes off and the water starts to flow again. After this happened on the last occasion, the light stayed on and now the shower will not work at all. Every time it is turned on the Low Pressure light comes on and no water comes out.

We have not had any work done on anything in the water system in the house and there is no obvious change in the water pressure at any of the taps etc.

Does anybody know of anything that can cause this other than water pressure? If so, is it fixable or am I stuck with an unworkable shower and/or low water pressure.

I would appreciate any ideas at all, not least since the consequences of not having access to a shower may soon may soon start to be apparent!
refurbish18
Posts: 6
Joined: Sun Jan 30, 2011 6:03 pm

Sponsor

Simply Build It

Postby stoneyboy » Sat Mar 12, 2011 6:58 pm

refurbish18,
If there is a filter in the supply to the shower - remove it and clean it.
end
stoneyboy
Posts: 2708
Joined: Wed Dec 10, 2008 6:44 pm


Postby refurbish18 » Mon Mar 14, 2011 4:10 pm

Thanks for that. I did wonder if that was a possible explanation. I am now stripping it down and looking at the inlet piping but so far cannot find any filters. I will report any progress, but any further ideas will be appreciated.
refurbish18
Posts: 6
Joined: Sun Jan 30, 2011 6:03 pm


Postby stoneyboy » Tue Mar 15, 2011 10:52 pm

refurbish18,
Filters may be a seperate item fitted anywhere in the supply pipework.
If you are in a hard water area it may be build up of limescale in the heater.
end
stoneyboy
Posts: 2708
Joined: Wed Dec 10, 2008 6:44 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics