Glowworm Flexicom CX30 Hot Water Problem


Postby Crowdog » Wed Dec 05, 2018 8:04 pm

I have a Glowworm Felxicom CX30. The central heating works just fine, however the hot water does not. The water does get hot but it does not stay hot, it goes cold and then hot again, repeating until displaying error F25.
I had someone to look at it and they told me it would be the heat exchange plate and slo that I need to install a filter.
So, heat exchange was taken off and clean with brick acid although I must say that it did not seem blocked - (I have taken off and repeated this cleaning 3 times in total now) - and I have fit a Magna Clean filter. The whole system has been drained after leaving in cleaning fluid and I have put some system inhibitor in.
Despite all I've done, I still have the same fault - hot then cold 3 time before error F25 come up.
I put the boiler in state Mode and left the hot tap running and below is the sequence it produces. I'm hoping someone can help with a proper diagnosis before we decide that a new boiler is the only option (rather not just before Christmas but we can't keep on with the current situation)

Hot water turned on - time below is when the state number is first displayed:
13
14 - 9 seconds
16
53 - 30 seconds
16
10 - 40 seconds
53
14 - 1 min 10 secs
3
98 - 1 min 28 secs
97 - 2 min 30 secs
13 - 2 min 38 secs
14 - 2 min 58 secs
53 - 3 min 38 secs
98 - 6 min 39 secs
F25 - 6 min 48 secs

I would massively appreciate help if anyone can.
Thanks in advance.
Crowdog
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Tue Dec 04, 2018 7:39 pm

Sponsor

Simply Build It


  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics